Degraded service in us-east

Incident Report for Normcore

Resolved

We've observed no issues since the fix was deployed. We're now considering this issue resolved.
Posted Nov 18, 2025 - 20:25 EST

Monitoring

Traffic is now being routed around the affected datacenter. All new room spin-ups are working correctly and existing room servers are still operational.
Posted Nov 18, 2025 - 16:42 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 18, 2025 - 16:40 EST

Investigating

We're seeing degraded network performance that is causing initial connections to rooms to fail in one of our us-east datacenters. We're currently routing traffic away from this datacenter and expect service to return to normal within 1-2 minutes.
Posted Nov 18, 2025 - 16:40 EST
This incident affected: Normcore Matcher, Normcore Room Servers, and Normcore Data Center Providers.